2015年12月22日 星期二

ubuntu 安装最新的软件

在使用ubuntu 时,使用apt-get 安装软件很方便,但是有些软件在此版本ubuntu下不是最新的。所有我们要配置最新的软件源。 首先到http://packages.ubuntu.com/网站搜索你要安装的软件,找到最新的话,查看你想要的版本在哪个类别。比如:  trusty 、trusty-backports 、 vivid  、 wily 。 然后再到http://wiki.ubuntu.org.cn/源列表 ,找软件元列表。 比如:

Vivid(15.04)版本

Ubuntu 官方更新服务器(欧洲,此为官方源,国内较慢,但无同步延迟问题,电信、移动/铁通、联通等公网用户可以使用):
deb http://archive.ubuntu.com/ubuntu/ vivid main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ vivid-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ vivid-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ vivid-proposed main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ vivid-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ vivid main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ vivid-security main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ vivid-updates main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ vivid-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ vivid-backports main restricted universe multiverse
如果你想使用wily类别软件,就把vivid替换成wily。 最后刷新列表:  
  • sudo apt-get update
  • 搜索 apt-cache search golang
  •  查看  apt-cache show golang
  • 安装 sudo apt-get install golang=2:1.5.1-0ubuntu2
2:1.5.1-0ubuntu2  是版本号